Not receiving the sign in email? Please try the below

Hi :wave:

It is possible that when trying to login to Plum, you will not be receiving the sign in email. This is especially true for users whose email domain is,, outlook, etc.) because of the way Microsoft has trained its filtering system.

In these cases it’s good to try whitelisting our sender address.

In case your email is not a Microsoft one and you are unsure how to do that for your email provider I would recommend checking out their help page.

The email address you will need to input is

To do this in

  1. Open your email account. Key in your password, etc., as required.
  2. Click “Options”. This is located at the top right part of your screen (below your email address).
  3. Click “Safe and blocked sender” under “Junk e-mail”.
  4. Click “Safe senders”
  5. Enter “”.
  6. Click “Add to list”.
  7. Check it’s operational by seeing that all the right boxes are checked. You’re done!

If you are still not receiving the email be sure to double check the junk folder. If it is not there, we would recommend contacting your email provider.

Thank you!

1 Like